Microsoft Identity Management 2016 : no-start-ma when trying to Export (with Exchange provisioning)

Microsoft-MIM

Recently, I had to used Microsoft Identity Manager 2016 for a customer project and had several troubles. We were using it with Exchange Provisioning in order to provision automatically new mailboxes in a Microsoft Exchange 2010 infrastructure.

Sometimes and for unknown reasons, we were getting the following errors not-start-ma. The Management Agents refused to launch and we had several errors in the Event Viewer.

This problem was really strange because this problem appeared after long development steps and for no apparent reasons because it was never after big changes or huge improvements… At the beginning, we used to revert our development virtual machine and it solved the problem (for a few days more). And after a while, it happened again !

If you had you too this problem, you will probably recognise the following errors messages and screenshots :

Faulting application name: miiserver.exe, version: 4.1.3419.0, time stamp: 0x511d9c79
Faulting module name: clr.dll, version: 4.0.30319.17929, time stamp: 0x4ffa59b1
Exception code: 0xc0000005
Fault offset: 0x00000000004e5900
Faulting process id: 0xf8c
Faulting application start time: 0x01cefcaa20d1eda1
Faulting application path: C:\Program Files\Microsoft Forefront Identity Manager\2010\Synchronization Service\Bin\miiserver.exe
Faulting module path: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll

Or maybe this one :

Faulting application name: miiserver.exe, version: 4.1.3419.0, time stamp: 0x511d9c79
Faulting module name: ntdll.dll, version: 6.1.7601.17514, time stamp: 0x4ce7c8f9
Exception code: 0xc0000005
Fault offset: 0x0000000000018e3d
Faulting process id: 0xed4
Faulting application start time: 0x01cefc16c915f872
Faulting application path: C:\Program Files\Microsoft Forefront Identity Manager\2010\Synchronization Service\Bin\miiserver.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll

These good articles put us on track to solve the problem :

Or maybe, these captures :

ERROR MIM_2

ERROR MIM_3

ERROR MIM_4

And finally, the solution was to install the Microsoft .NET 4.6.1 – and read me well : for us ; the Microsoft .NET 4.6 was not enough (as described in others cases) we needed the Microsoft .NET 4.6.1. After installed it, the problem was gone ! 🙂